Caddy running funny, cutting out. Crankshaft position sensor

Random Caddy chat.
Not the place for sale or wanted topics.
Post Reply
Freeman506
Caddy2k Groupie
Posts: 45
Joined: Fri Mar 06, 2015 9:02 pm
Engine size/power: 1.4 16V Petrol (74bhp)
Location: Wolverhampton

Caddy running funny, cutting out. Crankshaft position sensor

Post by Freeman506 » Mon Apr 06, 2015 8:48 pm

Alright all, sorry if this is in the wrong section but i got my caddy throwing a wobbler.
Basically, glow plug light flashes and about a mile down the road when foot is taken of the accelerator, it cuts out.
Had my guys take a look at it (specialise in VAG) and they put it down to a fault crankshaft position sensor. Changed it and nay bother for about a month.
Now all of a sudden its come back with a vengeance and won't start (keeps turning over until catches up on its fire order) starts up and cuts out again. Turn the key once more she starts a dream. Then down the road glow plug light comes on and cuts out again!
Stuck the code reader on it and it says P0726 Engine speed sensor, CKT range/performance. Surely it can't be the crankshaft position sensor again can it?
Any light on the situation will help please. Cheers

User avatar
Euro Technika
Caddy Fan
Posts: 77
Joined: Sun Dec 07, 2014 1:52 am
Engine size/power: 1.4 16V Petrol (74bhp)

Re: Caddy running funny, cutting out. Crankshaft position se

Post by Euro Technika » Mon Apr 06, 2015 9:46 pm

If you have replaced the crank angle sensor your next step should be checking all the wires from the crank sensor to the ecu. If all wires test ok further checks will be needed what's your engine and engine code.

Freeman506
Caddy2k Groupie
Posts: 45
Joined: Fri Mar 06, 2015 9:02 pm
Engine size/power: 1.4 16V Petrol (74bhp)
Location: Wolverhampton

Re: Caddy running funny, cutting out. Crankshaft position se

Post by Freeman506 » Tue Apr 07, 2015 9:07 am

Just went to where I get all my things done and they said to check that or they will send the ECU off! :(
I'll have to have a look during work later.
Thanks

sutton1001
100BHP+
Posts: 139
Joined: Mon Mar 23, 2015 6:35 pm
Engine size/power: 1.4 16V Petrol (74bhp)

Re: Caddy running funny, cutting out. Crankshaft position se

Post by sutton1001 » Wed Apr 15, 2015 5:52 pm

Did you get to the bottom of your problem?

I've just put my van in as having starting problems. Their changing speed sensor and cam sensor!

Freeman506
Caddy2k Groupie
Posts: 45
Joined: Fri Mar 06, 2015 9:02 pm
Engine size/power: 1.4 16V Petrol (74bhp)
Location: Wolverhampton

Re: Caddy running funny, cutting out. Crankshaft position se

Post by Freeman506 » Tue May 12, 2015 5:54 pm

Yeah, well apparently the wire that was running to the crank shaft sensor had been previously repaired what seemed to be by the chuckle brothers. So my geezer chopped that wiring out and connected it all good and proper, since then she hasn't let me down (taps on the wood surface) :)

Also i heard sometimes they have trouble starting don't they? Or was that pork eyes someone was telling me? Aha

Post Reply

Who is online

Users browsing this forum: Bluebeard, Google [Bot], Jezzaroo, Padster and 1 guest