Noob rear camera pain...

Random Caddy chat.
Not the place for sale or wanted topics.
User avatar
Tp88
Caddy Fan
Posts: 95
Joined: Sat Apr 07, 2018 10:20 am
Engine size/power: 1.9 TDI (104bhp)
Contact:

Noob rear camera pain...

Post by Tp88 » Tue May 29, 2018 8:30 pm

The classic newbie question of all time *face palm*

I’ve installed a rear camera but can’t for the life work out how to wire it in regardless of trawling the forums and web. Can’t work out what I’m doing wrong.

I started by wiring it into the reverse light as many folk have said, which works perfectly until the engine is on.

I then move to the rear wiper but as it’s a constant 12V once it’s in reverse, it all works but the lights on the camera never go off so I assume it’s running power too it all the time. I was hoping I would t have to faf with a relay but I’m assuming that’s going to be the answer?

Help much appreciate... getting to the point where I’m gonna rip it all out soon!


Sent from my iPhone using Tapatalk

User avatar
Liam
Hyper Poster
Posts: 3104
Joined: Wed Nov 18, 2009 9:47 am
Engine size/power: 2.0 TDI (140bhp)
Location: Cavan

Re: Noob rear camera pain...

Post by Liam » Tue May 29, 2018 8:52 pm

Brooneye has just finished installing his maybe he could help out here
2016 2.0 Tdi Mk4 Trendline caddy 160bhp
Remapped by Joe Power at TDR.ie www.tdr.ie
Build thread here
http://caddy2k.com/forum/viewtopic.php?t=34976

totty79
100BHP+
Posts: 197
Joined: Mon May 22, 2017 9:04 am
Engine size/power: 1.6 CR TDI (102bhp)

Re: Noob rear camera pain...

Post by totty79 » Tue May 29, 2018 9:24 pm

What head unit?
If it's an android one with an external canbus box you can tap into the canbus to head unit reverse wife to trigger a relay and use that to power the camera.

User avatar
mostlysimon
200BHP+
Posts: 265
Joined: Mon Nov 18, 2013 4:40 pm
Engine size/power: 1.9 TDI (104bhp)
Location: Stokesley

Re: Noob rear camera pain...

Post by mostlysimon » Tue May 29, 2018 9:53 pm

totty79 wrote:
Tue May 29, 2018 9:24 pm
What head unit?
If it's an android one with an external canbus box you can tap into the canbus to head unit reverse wife to trigger a relay and use that to power the camera.
According to this 'how-to': http://caddy2k.com/forum/viewtopic.php? ... ra#p254121 the canbus reverse wire is +12V so can splice straight into the camera power.

I'm about to do the same thing so it's a question as much as a suggestion!

User avatar
Tp88
Caddy Fan
Posts: 95
Joined: Sat Apr 07, 2018 10:20 am
Engine size/power: 1.9 TDI (104bhp)
Contact:

Re: Noob rear camera pain...

Post by Tp88 » Tue May 29, 2018 10:04 pm

My radio already has a canbus built in :-/ is that what you meant?


Sent from my iPhone using Tapatalk

User avatar
Tp88
Caddy Fan
Posts: 95
Joined: Sat Apr 07, 2018 10:20 am
Engine size/power: 1.9 TDI (104bhp)
Contact:

Re: Noob rear camera pain...

Post by Tp88 » Tue May 29, 2018 10:06 pm

totty79 wrote:What head unit?
If it's an android one with an external canbus box you can tap into the canbus to head unit reverse wife to trigger a relay and use that to power the camera.
It’s an Android RNS510 knock off with a canbus built in. Also has a wire for a sub which puts out a pretty hefty voltage but I’m not sure where start with a relay in honesty!


Sent from my iPhone using Tapatalk

User avatar
Tp88
Caddy Fan
Posts: 95
Joined: Sat Apr 07, 2018 10:20 am
Engine size/power: 1.9 TDI (104bhp)
Contact:

Re: Noob rear camera pain...

Post by Tp88 » Tue May 29, 2018 10:06 pm

Liam wrote:Brooneye has just finished installing his maybe he could help out here
Cheers liam! Just asked the question.


Sent from my iPhone using Tapatalk

totty79
100BHP+
Posts: 197
Joined: Mon May 22, 2017 9:04 am
Engine size/power: 1.6 CR TDI (102bhp)

Re: Noob rear camera pain...

Post by totty79 » Wed May 30, 2018 1:24 pm

Regarding the canbus reverse wire I'm sure that would work. I wanted mine on a separately fused feed from the fuse box, just to limit any damage if it shorted.

I'm not familiar with the Android RNS510 knock off, but ......
Output for sub is normally a mono audio and a 12v signal to turn the amp on. Anything using a higher voltage would be very unusual.
Relays just use one circuit to switch another. You've already tapped into both the rear wiper and the reverse light, so you could try the following - buy a relay and connect as follows connect terminal 85 to earth, 86 to reverse light, 87 to reverse camera positive, 30 to rear wiper positive, camera negative also to earth (double check the terminals using the diagram on the relay or it's packaging). Provided the canbus reversing lights switch the relay OK (I've read elsewhere that they do) then the camera will only be powered when in reverse.

User avatar
brooneye
Hyper Poster
Posts: 824
Joined: Sun Jan 17, 2016 6:51 pm
Engine size/power: 1.8 20V Turbo

Re: Noob rear camera pain...

Post by brooneye » Wed May 30, 2018 2:00 pm

By doing it the way I mentioned the camera only powers up on the screen when reverse is selected. It’s a case of 1 wire from under the steering wheel to the trigger wire on the back of the head unit


Sent from my iPhone using Tapatalk

User avatar
brooneye
Hyper Poster
Posts: 824
Joined: Sun Jan 17, 2016 6:51 pm
Engine size/power: 1.8 20V Turbo

Re: Noob rear camera pain...

Post by brooneye » Wed May 30, 2018 2:02 pm

Apologies just seen this is in a thread that the op started and then he asked in my thread where there is details on how I done it


Sent from my iPhone using Tapatalk

User avatar
Tp88
Caddy Fan
Posts: 95
Joined: Sat Apr 07, 2018 10:20 am
Engine size/power: 1.9 TDI (104bhp)
Contact:

Re: Noob rear camera pain...

Post by Tp88 » Fri Jun 01, 2018 7:12 pm

So I’ve sorted a relay out, seems to have done the trick but the image is still flickering?

30 - Power from wiper
86 - Switch from reverse light
85 - Earth from van chassis
87 - power to camera

What am I doing wrong?



Sent from my iPhone using Tapatalk

totty79
100BHP+
Posts: 197
Joined: Mon May 22, 2017 9:04 am
Engine size/power: 1.6 CR TDI (102bhp)

Re: Noob rear camera pain...

Post by totty79 » Fri Jun 01, 2018 8:08 pm

Flickering all the time or only with the engine running?
I'd run a temporary live straight from the battery as a test, to see if the flickering is caused by the power source or not.

User avatar
brooneye
Hyper Poster
Posts: 824
Joined: Sun Jan 17, 2016 6:51 pm
Engine size/power: 1.8 20V Turbo

Re: Noob rear camera pain...

Post by brooneye » Fri Jun 01, 2018 8:36 pm

You sure your not using th reverse light for power? I made that mistake and had the dreaded flickering


Sent from my iPhone using Tapatalk

User avatar
Tp88
Caddy Fan
Posts: 95
Joined: Sat Apr 07, 2018 10:20 am
Engine size/power: 1.9 TDI (104bhp)
Contact:

Re: Noob rear camera pain...

Post by Tp88 » Fri Jun 01, 2018 10:19 pm

brooneye wrote:You sure your not using th reverse light for power? I made that mistake and had the dreaded flickering


Sent from my iPhone using Tapatalk
Yeah sure it’s not that. Can’t figure it out... god damn camera! Bane of my life ATM!


Sent from my iPhone using Tapatalk

User avatar
brooneye
Hyper Poster
Posts: 824
Joined: Sun Jan 17, 2016 6:51 pm
Engine size/power: 1.8 20V Turbo

Re: Noob rear camera pain...

Post by brooneye » Sat Jun 02, 2018 12:34 pm

I don’t understand where your going wrong and why you need a relay.

I thought my wireless transmitters were not working so I used the hard wire to test. You should have one of these

Image

Black wire to pin 5 on rear wiper and red to pin 1 on wiper. That will give you early and power to the camera.

Run this cable

Image

One end in the camera plug and one end in the brown port on the back of the head unit

Next is the trigger wire use plug 3 pin 12 on the cecm should have a blue trace. Solder a bit of the wire that you cut off the top of the thick camera cable to that pin out and then to the back of the head unit

Image

Hook everything up and try with your engine running. The only time I had the flicker was when I mistakenly used the reverse light for power


Sent from my iPhone using Tapatalk

Post Reply