Reverse camera issues.

Random Caddy chat.
Not the place for sale or wanted topics.
User avatar
the swan fiend
Hyper Poster
Posts: 1318
Joined: Sat Feb 18, 2017 10:52 pm
Engine size/power: 1.6 CR TDI (102bhp)

Reverse camera issues.

Post by the swan fiend » Tue Nov 26, 2019 6:56 pm

Image

This is a crude wiring diagram of how I’ve wired my reverse cam up. When I put it in reverse, the stereo triggers, but the screen stays black.
I’ve checked the power lead to the camera with my multimeter and it’s saying I have power. I’m wondering weather the RCA lead or camera itself is faulty. I’m going to test the RCA lead for continuity tomorrow.
At a loss with this....what have I done wrong?


Sent from my iPhone using Tapatalk
Last edited by the swan fiend on Tue Nov 26, 2019 6:56 pm, edited 1 time in total.
Rescue me from the swans in me

User avatar
maxx007at
Twin Turbo poster
Posts: 313
Joined: Wed Feb 04, 2015 9:58 pm
Engine size/power: 1.9 TDI (104bhp)
Location: Nieuwe Niedorp, North Holland, Netherlands

Re: Reverse camera issues.

Post by maxx007at » Tue Nov 26, 2019 7:01 pm

the swan fiend wrote:Image

This is a crude wiring diagram of how I’ve wired my reverse cam up. When I put it in reverse, the stereo triggers, but the screen stays black.
At a loss with this....what have I done wrong?


Sent from my iPhone using Tapatalk
What did you connect the trigger wire to?

And do you have power on the reverse camera?
Caddy 2k (e.o.2004) (1.9 TDI(BJB), REMAP 103KW/145PS) Ravenna Blue
Passat 3C heated front seats, Premium 3D Color Cluster

User avatar
the swan fiend
Hyper Poster
Posts: 1318
Joined: Sat Feb 18, 2017 10:52 pm
Engine size/power: 1.6 CR TDI (102bhp)

Re: Reverse camera issues.

Post by the swan fiend » Tue Nov 26, 2019 7:04 pm

Trigger wire goes from head unit to pin 87 on relay, camera power goes direct to ignition live on fuse box, input 30.


Sent from my iPhone using Tapatalk
Rescue me from the swans in me

User avatar
maxx007at
Twin Turbo poster
Posts: 313
Joined: Wed Feb 04, 2015 9:58 pm
Engine size/power: 1.9 TDI (104bhp)
Location: Nieuwe Niedorp, North Holland, Netherlands

Re: Reverse camera issues.

Post by maxx007at » Tue Nov 26, 2019 7:11 pm

I’d suggest putting a switched power on the camera, leave out the relay, unless it switches your headunit off when you turn the ignition off.

The triggerwire in the rca cable can be use to connect your reverse lightpower to the reverse light input on your headunit, so it will then be used as a trigger for your headunit.
Caddy 2k (e.o.2004) (1.9 TDI(BJB), REMAP 103KW/145PS) Ravenna Blue
Passat 3C heated front seats, Premium 3D Color Cluster

User avatar
the swan fiend
Hyper Poster
Posts: 1318
Joined: Sat Feb 18, 2017 10:52 pm
Engine size/power: 1.6 CR TDI (102bhp)

Re: Reverse camera issues.

Post by the swan fiend » Tue Nov 26, 2019 7:22 pm

I’ve put the relay in myself mate to act as the trigger. As far as I’m aware, the reverse light can’t be used for the trigger as it’s not a clean feed.


Sent from my iPhone using Tapatalk
Rescue me from the swans in me

User avatar
Rigpig
100BHP+
Posts: 134
Joined: Thu Mar 16, 2017 4:45 pm
Engine size/power: 1.9 TDI (104bhp)
Location: Inverurie, Aberdeenshire

Re: Reverse camera issues.

Post by Rigpig » Tue Nov 26, 2019 7:28 pm

Hi Swan Fiend.

I have a cheapo camera and a Pioneer SPH-DA120
and wired mine like this.

Pin 87 on the relay I connected the wire that goes to the trigger wire on the back of the head unit. If you have a red wire coming from your RCA plug, use this, and the other end to the head unit wire. Mine was purple on the Pioneer.

Pin 86 on the relay, I tapped in a wire from the reverse light.

Pin 30 on the relay I tied in a feed from the wiper motor 12v supply and the camera power wire.

Pin 85 on the relay, I tied it in to the earth line on the camera and the earth wire on the window wiper plug.

I soldered all required connections, and made sure everything was insulated

Mine works perfectly.




Sent from my iPhone using Tapatalk

User avatar
the swan fiend
Hyper Poster
Posts: 1318
Joined: Sat Feb 18, 2017 10:52 pm
Engine size/power: 1.6 CR TDI (102bhp)

Re: Reverse camera issues.

Post by the swan fiend » Tue Nov 26, 2019 7:43 pm

Cheers rigpig.
Straight away I can see the difference in our wiring. I’ll look into doing these changes tomorrow and see what’s what.


Sent from my iPhone using Tapatalk
Rescue me from the swans in me

User avatar
the swan fiend
Hyper Poster
Posts: 1318
Joined: Sat Feb 18, 2017 10:52 pm
Engine size/power: 1.6 CR TDI (102bhp)

Re: Reverse camera issues.

Post by the swan fiend » Tue Nov 26, 2019 7:51 pm

Rigpig would you mind explaining again how you did pin 87? It’s not making sense to me....I thought it did before!


Sent from my iPhone using Tapatalk
Rescue me from the swans in me

Ryzar1
Caddy Fan
Posts: 98
Joined: Fri Aug 16, 2019 12:22 am
Engine size/power: 1.9 TDI (104bhp)

Re: Reverse camera issues.

Post by Ryzar1 » Tue Nov 26, 2019 7:52 pm

Mine had an issue triggering had to put an extra earth behind the head unit and sometimes I have to move it around so the damn thing will work again


Sent from my iPhone using Tapatalk

User avatar
the swan fiend
Hyper Poster
Posts: 1318
Joined: Sat Feb 18, 2017 10:52 pm
Engine size/power: 1.6 CR TDI (102bhp)

Re: Reverse camera issues.

Post by the swan fiend » Tue Nov 26, 2019 7:55 pm

Mine is triggering ok mate. I’m just not getting a picture


Sent from my iPhone using Tapatalk
Rescue me from the swans in me

User avatar
Rigpig
100BHP+
Posts: 134
Joined: Thu Mar 16, 2017 4:45 pm
Engine size/power: 1.9 TDI (104bhp)
Location: Inverurie, Aberdeenshire

Re: Reverse camera issues.

Post by Rigpig » Tue Nov 26, 2019 9:25 pm

This is how I have it mate.

Just ask if you need anything else. Cheers

Image


Sent from my iPhone using Tapatalk

User avatar
the swan fiend
Hyper Poster
Posts: 1318
Joined: Sat Feb 18, 2017 10:52 pm
Engine size/power: 1.6 CR TDI (102bhp)

Re: Reverse camera issues.

Post by the swan fiend » Tue Nov 26, 2019 9:36 pm

That’s brilliant mate. I will study it now. Thankyou very much


Sent from my iPhone using Tapatalk
Rescue me from the swans in me

User avatar
r1lea
Hyper Poster
Posts: 835
Joined: Sat Dec 29, 2018 1:23 am

Re: Reverse camera issues.

Post by r1lea » Tue Nov 26, 2019 9:40 pm

That’s not ideal

You want a clean 12v to the camera from the output of pin 87 from the relay




Sent from my iPhone using Tapatalk

User avatar
r1lea
Hyper Poster
Posts: 835
Joined: Sat Dec 29, 2018 1:23 am

Re: Reverse camera issues.

Post by r1lea » Tue Nov 26, 2019 9:45 pm

Image


Sent from my iPhone using Tapatalk

User avatar
the swan fiend
Hyper Poster
Posts: 1318
Joined: Sat Feb 18, 2017 10:52 pm
Engine size/power: 1.6 CR TDI (102bhp)

Re: Reverse camera issues.

Post by the swan fiend » Tue Nov 26, 2019 9:54 pm

Ahh ok. I can sort that out. That leaves me unsure of where to put the trigger wire now.


Sent from my iPhone using Tapatalk
Rescue me from the swans in me

Post Reply