2.0 sdi won’t start.

Random Caddy chat.
Not the place for sale or wanted topics.
Sifu
Caddy2k Groupie
Posts: 29
Joined: Tue Oct 10, 2017 7:50 pm
Engine size/power: 2.0 SDI (70bhp)

2.0 sdi won’t start.

Post by Sifu » Thu Nov 19, 2020 5:09 pm

Had issues with the van. I made the mistake of turning the key straight on , not allowing any warm up time and it didn’t start. Turned it off tried again and nothing. Will turn over but won’t fire. Took to a garage who couldn’t find any codes thrown up . They changed the fuel lift pump but it’s not cured it. I can get it started with a dose of easy start and then as long as I let it warm up it will start but it’s not running smoothly. Today it cut out whilst I was driving it managed to bump it back into life. I thought it might be the 109 relay but it appears I don’t have one on this engine ( 09 2.0 sdi ). I m running out of ideas any help would be great.

User avatar
C Chis
Hyper Poster
Posts: 713
Joined: Fri Mar 06, 2020 1:13 pm

Re: 2.0 sdi won’t start.

Post by C Chis » Thu Nov 19, 2020 6:19 pm

Have you ran a scan on the van yet, if not then I would start there...

It could be your glow plugs have failed and it’s now not starting as the weather is colder!


Sent from my iPad using Tapatalk
My MTB Caddy Build Can be Found Here

User avatar
C Chis
Hyper Poster
Posts: 713
Joined: Fri Mar 06, 2020 1:13 pm

Re: 2.0 sdi won’t start.

Post by C Chis » Thu Nov 19, 2020 6:22 pm

You can check your glow plugs quite easily, they should have a resistance of <1 Ohm, starting to fail if they are >1 but <5 Ohms and need replaced if > 5 Ohms or open circuit.


Sent from my iPad using Tapatalk
My MTB Caddy Build Can be Found Here

Sifu
Caddy2k Groupie
Posts: 29
Joined: Tue Oct 10, 2017 7:50 pm
Engine size/power: 2.0 SDI (70bhp)

Re: 2.0 sdi won’t start.

Post by Sifu » Thu Nov 19, 2020 6:33 pm

Van scanned code free apparently. I don’t think it’s glow plugs as when is does fail it won’t start again no matter what. As if there is something stopping the fuel from coming through. Also it cut out whilst running so glow plug weren’t in play then, I m guessing.

User avatar
C Chis
Hyper Poster
Posts: 713
Joined: Fri Mar 06, 2020 1:13 pm

Re: 2.0 sdi won’t start.

Post by C Chis » Thu Nov 19, 2020 8:53 pm

Ah, doesn’t sound like glow plugs then. Let us know you get on...


Sent from my iPad using Tapatalk
My MTB Caddy Build Can be Found Here

Oskai
Caddy2k Groupie
Posts: 24
Joined: Sat Sep 05, 2020 12:55 pm
Engine size/power: 2.0 SDI (70bhp)

Re: 2.0 sdi won’t start.

Post by Oskai » Thu Nov 19, 2020 8:55 pm

Is it smoking when running? Could be injector seals as when they're gone it won't start very well when it's cold

Sifu
Caddy2k Groupie
Posts: 29
Joined: Tue Oct 10, 2017 7:50 pm
Engine size/power: 2.0 SDI (70bhp)

Re: 2.0 sdi won’t start.

Post by Sifu » Thu Nov 19, 2020 9:25 pm

No sign of smoke either. If it had a 109 relay I would say it was that as other things I ve read suggest these are an issue but this engine doesn’t appear to have one. Bit of a head scratcher. Thanks for the help anyway.

User avatar
Doc
Not God, just a bellend
Posts: 14584
Joined: Thu Jan 01, 1970 1:00 am
Engine size/power: 2.0TSI EA888 Gen3
Location: Monaghan, Ireland & Leicestershire, UK

Re: 2.0 sdi won’t start.

Post by Doc » Thu Nov 19, 2020 9:31 pm

What is this 109 relay you talk about?
Image
Image
2013 Caddy with EA888 Gen3 2.0TSI DSG, Superplus MSP19 , Caddy4 rear lights, Polo GTI (mk7 style) steering wheel, Relentless Tuning front coilovers, Audi A6 S-Line front seats, Boxster fronts & GTI rear Brakes, 3D Colour Premium dash cluster, Caddy life arm rest, Motexion bulkhead, MIB head unit


I have genuine VCDS Hex V2 & VagCAN Pro for any of your programming needs.

Sifu
Caddy2k Groupie
Posts: 29
Joined: Tue Oct 10, 2017 7:50 pm
Engine size/power: 2.0 SDI (70bhp)

Re: 2.0 sdi won’t start.

Post by Sifu » Thu Nov 19, 2020 9:42 pm

Well from what I read there is a relay that controls the fuel pump ( has 109 printed on it ) . That is prone to packing up and can cause the same symptoms as I ve got. This is purely from google searching so could easily be wrong. From what I surmised this controls the signal to the fuel pump and when it plays up you get no fuel through.

User avatar
Doc
Not God, just a bellend
Posts: 14584
Joined: Thu Jan 01, 1970 1:00 am
Engine size/power: 2.0TSI EA888 Gen3
Location: Monaghan, Ireland & Leicestershire, UK

Re: 2.0 sdi won’t start.

Post by Doc » Thu Nov 19, 2020 9:45 pm

When you turn your ignition on, do you hear the pump prime the fuel system?
Try it a few times first thing in the morning, about 30 seconds apart.

If it starts to sound as though it's struggling after the their time, you might have a problem with fuel returning to the tank which is very common.
Image
Image
2013 Caddy with EA888 Gen3 2.0TSI DSG, Superplus MSP19 , Caddy4 rear lights, Polo GTI (mk7 style) steering wheel, Relentless Tuning front coilovers, Audi A6 S-Line front seats, Boxster fronts & GTI rear Brakes, 3D Colour Premium dash cluster, Caddy life arm rest, Motexion bulkhead, MIB head unit


I have genuine VCDS Hex V2 & VagCAN Pro for any of your programming needs.

Sifu
Caddy2k Groupie
Posts: 29
Joined: Tue Oct 10, 2017 7:50 pm
Engine size/power: 2.0 SDI (70bhp)

Re: 2.0 sdi won’t start.

Post by Sifu » Thu Nov 19, 2020 9:51 pm

Just tried that . It sounds the same each time. The garage did replace the lift pump in the tank.

User avatar
Doc
Not God, just a bellend
Posts: 14584
Joined: Thu Jan 01, 1970 1:00 am
Engine size/power: 2.0TSI EA888 Gen3
Location: Monaghan, Ireland & Leicestershire, UK

Re: 2.0 sdi won’t start.

Post by Doc » Thu Nov 19, 2020 9:54 pm

Ok, if you are hearing you pump prime up each time, I'm gonna say your relay is fine.
Image
Image
2013 Caddy with EA888 Gen3 2.0TSI DSG, Superplus MSP19 , Caddy4 rear lights, Polo GTI (mk7 style) steering wheel, Relentless Tuning front coilovers, Audi A6 S-Line front seats, Boxster fronts & GTI rear Brakes, 3D Colour Premium dash cluster, Caddy life arm rest, Motexion bulkhead, MIB head unit


I have genuine VCDS Hex V2 & VagCAN Pro for any of your programming needs.

Sifu
Caddy2k Groupie
Posts: 29
Joined: Tue Oct 10, 2017 7:50 pm
Engine size/power: 2.0 SDI (70bhp)

Re: 2.0 sdi won’t start.

Post by Sifu » Fri Nov 20, 2020 6:00 pm

Any ideas what it could be.

User avatar
Lcm evolution
Caddy2k Groupie
Posts: 19
Joined: Wed Nov 02, 2016 8:11 pm
Engine size/power: 1.9 TDI (74bhp)

Re: 2.0 sdi won’t start.

Post by Lcm evolution » Fri Nov 27, 2020 5:42 pm

Hi there,

is the cambelt ok ,?
iv seen some stretched so much that the torsen value comes so far out it wont fire as the cam sensor is seiing bad readings,

does it fire and stay running on idle ?

Sifu
Caddy2k Groupie
Posts: 29
Joined: Tue Oct 10, 2017 7:50 pm
Engine size/power: 2.0 SDI (70bhp)

Re: 2.0 sdi won’t start.

Post by Sifu » Sun Nov 29, 2020 5:31 pm

Will start and run on idle if it’s been used recently but if it’s been left a few hours it won’t start. Seems to lock out . Only way to start it is with easy start if that happens.

Post Reply